Freem Movies Not Working

Freem Movies Not Working

Anonymous's picture

Yeah, I am able to view a few of the free movies on here, but several will not start, like Warlock. I wanted to see it, but it won't start. help?

Edited by SleepAwayCampVictim on 4/17/2007 at 09:31 EST

Share this discussion

JuLeeeX84's picture

I am having the same problem. I am always having a problem watching movies. Sometimes itll work for a week or so then sometimes it doesnt. I thought maybe its my computer but when i tried on 3 other computers of my siblings, its the same thing. i barely visit this site now becuase of it. Its soo annoying, I dont understand what is the problem.

corpseofcourse's picture

my problem with them is not the loading but that they will have to rebuff every two minutes. now i know u might say i need a faster connection and thats probably true. but before they changed the site i used to be able to let the videos play once and just do somethin else. then id go back and watch it the 2nd time and it would play flawlessly. now when i play it the 2nd time i cant. it just says something like buffing nan. so i let it play and stop it before the credits but it plays as if it was playing the first time through. it has to rebuff every 2 minutes. now theres the red bar and i assume thats how much of the movie has loaded but i try to just slide the triangular markers but the red bar goes with it. any suggestions or am i just screwed and need cable instead of dsl or whatever.

Add new comment

Please login or register to post in the message boards.
By submitting this form, you accept the Mollom privacy policy.
<none>